1С Предприятие 8.0. Описание встроенного языка



              

Формат программного модуля - часть 2


Пример:

-метка:А=В;

Имена переменных, процедур и функций

Именем переменной, объявленной процедуры или функции, может быть любая последовательность букв, цифр и знаков подчеркивания "_", начинающаяся с буквы или знака подчеркивания "_". Вновь создаваемые имена не должны совпадать с зарезервированными словами языка или именами свойств, непосредственно доступных в текущем контексте. Распознавание имен переменных, процедур и функций ведется без учета регистра букв.

Язык написания программных модулей

Встроенный язык 1С:Предприятия является двуязычным. Почти все зарезервированные слова, имена типов значений, свойств, методов, событий имеют два имени: русское и английское. Исключение составляю слова, не имеющие аналогов в русском языке. В тесте программных модулей эти имена можно свободно смешивать, используя то русские, то английские имена без каких-либо ограничений.

Регистры букв при написании программных модулей

Регистр букв (строчные или заглавные) при написании имен переменных, свойств, методов, процедур, функций, а также функций встроенного языка не имеет значения.

Зарезервированные слова

Приведенные далее ключевые слова являются зарезервиро­ванными и не могут использоваться в качестве создаваемых имен переменных, реквизитов объектов конфигурации и объявляемых процедур и функций. В данном варианте языка каждое из ключевых слов имеет два представления - русское и английское.

Русское имя

Английское имя

Если

If

Тогда

Then

ИначеЕсли

Elsif

Иначе

Else

КонецЕсли

End If

Для

For

Каждого

Each

Из

In

По

To

Пока

While

Цикл

Do

КонецЦикла

End Do

Процедура

Procedure

Функция

Function

КонецПроцедуры

End Procedure

КонецФункции

EndFunction

Перем

Var

Перейти

Goto

Возврат

Return

Продолжить

Continue

Прервать

Break

И

And

Или

Or

Не

Not

Попытка

Try

Исключение

Except

ВызватьИсключение

Raise

КонецПопытки

EndTry

Новый

New

Выполнить

Execute

«««««««««« 1С:Предприятие 8.0 »»»»»»»»»»




Содержание  Назад  Вперед