1С Предприятие 8.0. Описание встроенного языка



              

Способы обхода результата запроса - часть 4


    Выборка = РезультатЗапроса.Выбрать(СпособВыборки);

    // Пока в выборке есть записи ...

    Пока Выборка.Следующий() Цикл

        // ... выведем в окно сообщений доля из результата

        Товар = Выборка.Наименование;

        Количество = Выборка.Количество;

        Сообщить("Товар: " + Товар + " Итого по товару: " + Количество) ;

        ВыдатьДочерниеЗаписи(Выборка.Выбрать()) ;

    КонецЦикла;

КонецПроцедуры

Процедура ВыдатьДочерниеЗапися (Выборка)

    // Пока в выборке есть записи . . .

    Пока Выборка.Следующий() Цикл

        // ... выведем в окно сообщений поля из результата

        Товар = Выборка.Наименование;

        Количество = Выборка.Количество;

        Сообщить("Товар: " + Товар + " Количество: " + Количество);

    КонецЦикла;

КонецПроцедуры




Содержание  Назад  Вперед